import Foundation
let pattern = #"(?=.*(\b\w{3}\b))(?=.*(\b\d{4}\b)).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
Oct-2013
2013-Oct
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1-$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)