re = /(?=.*(\b\w{3}\b))(?=.*(\b\d{4}\b)).*/im
str = 'Oct-2013
2013-Oct'
subst = '$1-$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result