$re = '~(?=.*(\b\w{3}\b))(?=.*(\b\d{4}\b)).*~im';
$str = 'Oct-2013
2013-Oct';
$subst = "$1-$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;