const regex = new RegExp('(?=.*(\\b\\w{3}\\b))(?=.*(\\b\\d{4}\\b)).*', 'gim')
const str = `Oct-2013
2013-Oct`;
const subst = `$1-$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);