#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)(?=.*(\b\w{3}\b))(?=.*(\b\d{4}\b)).*"
Local $sString = "Oct-2013" & @CRLF & _
"2013-Oct"
Local $sSubst = "$1-$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)