use strict;
my $str = 'Oct-2013
2013-Oct';
my $regex = qr~(?=.*(\b\w{3}\b))(?=.*(\b\d{4}\b)).*~imp;
my $subst = '$1-$2';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";