using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=.*(\b\w{3}\b))(?=.*(\b\d{4}\b)).*";
string substitution = @"$1-$2";
string input = @"Oct-2013
2013-Oct";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}