# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.{1,12}\w)\W.*$/\1.../gmu;t' <<< "Lorem ipsum dolor
Lorem ipsum? dolor
Lorem ipsum! dolor
Lorem ipsum. dolor
Lorem ipsum, dolor
Стихи похожи: на людей по"