package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.{1,12}\w)\W.*$`)
var str = `Lorem ipsum dolor
Lorem ipsum? dolor
Lorem ipsum! dolor
Lorem ipsum. dolor
Lorem ipsum, dolor
Стихи похожи: на людей по`
var substitution = "\1..."
fmt.Println(re.ReplaceAllString(str, substitution))
}