import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"^(.{1,12}\w)\W.*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Lorem ipsum dolor
Lorem ipsum? dolor
Lorem ipsum! dolor
Lorem ipsum. dolor
Lorem ipsum, dolor
Стихи похожи: на людей по
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1..."#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)