#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mu)^(.{1,12}\w)\W.*$"
Local $sString = "Lorem ipsum dolor" & @CRLF & _
"Lorem ipsum? dolor" & @CRLF & _
"Lorem ipsum! dolor" & @CRLF & _
"Lorem ipsum. dolor" & @CRLF & _
"Lorem ipsum, dolor" & @CRLF & _
"Стихи похожи: на людей по"
Local $sSubst = "\1..."
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)