use strict;
my $str = 'Lorem ipsum dolor
Lorem ipsum? dolor
Lorem ipsum! dolor
Lorem ipsum. dolor
Lorem ipsum, dolor
Стихи похожи: на людей по';
my $regex = qr/^(.{1,12}\w)\W.*$/mup;
my $subst = '\\1...';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";