$re = '/^(.{1,12}\w)\W.*$/mu';
$str = 'Lorem ipsum dolor
Lorem ipsum? dolor
Lorem ipsum! dolor
Lorem ipsum. dolor
Lorem ipsum, dolor
Стихи похожи: на людей по';
$subst = "\1...";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;