re = /^(.{1,12}\w)\W.*$/m
str = 'Lorem ipsum dolor
Lorem ipsum? dolor
Lorem ipsum! dolor
Lorem ipsum. dolor
Lorem ipsum, dolor
Стихи похожи: на людей по'
subst = '\\1...'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result