// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mu)^(.{1,12}\w)\W.*$").unwrap();
let string = "Lorem ipsum dolor
Lorem ipsum? dolor
Lorem ipsum! dolor
Lorem ipsum. dolor
Lorem ipsum, dolor
Стихи похожи: на людей по";
let substitution = "\\1...";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}