# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\w)(.+?)(@)(\w)(.+?)(.\w+$)/$1*****$3$4*****$6/gm;t' <<< "jaojao-pe-de-feijao.brasileiro@fortalnet.com.br
aristides.souza-ce@sistemas.auditivo.gov.eu.sis.at"