package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w)(.+?)(@)(\w)(.+?)(.\w+$)`)
var str = `jaojao-pe-de-feijao.brasileiro@fortalnet.com.br
aristides.souza-ce@sistemas.auditivo.gov.eu.sis.at`
var substitution = "$1*****$3$4*****$6"
fmt.Println(re.ReplaceAllString(str, substitution))
}