using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w)(.+?)(@)(\w)(.+?)(.\w+$)";
string substitution = @"$1*****$3$4*****$6";
string input = @"jaojao-pe-de-feijao.brasileiro@fortalnet.com.br
aristides.souza-ce@sistemas.auditivo.gov.eu.sis.at";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}