re = /(\w)(.+?)(@)(\w)(.+?)(.\w+$)/m
str = 'jaojao-pe-de-feijao.brasileiro@fortalnet.com.br
aristides.souza-ce@sistemas.auditivo.gov.eu.sis.at'
subst = '$1*****$3$4*****$6'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result