#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\w)(.+?)(@)(\w)(.+?)(.\w+$)"
Local $sString = "jaojao-pe-de-feijao.brasileiro@fortalnet.com.br" & @CRLF & _
"aristides.souza-ce@sistemas.auditivo.gov.eu.sis.at"
Local $sSubst = "$1*****$3$4*****$6"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)