const regex = /(\w)(.+?)(@)(\w)(.+?)(.\w+$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w)(.+?)(@)(\\w)(.+?)(.\\w+$)', 'gm')
const str = `jaojao-pe-de-feijao.brasileiro@fortalnet.com.br
aristides.souza-ce@sistemas.auditivo.gov.eu.sis.at`;
const subst = `$1*****$3$4*****$6`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);