use strict;
my $str = 'jaojao-pe-de-feijao.brasileiro@fortalnet.com.br
aristides.souza-ce@sistemas.auditivo.gov.eu.sis.at';
my $regex = qr/(\w)(.+?)(@)(\w)(.+?)(.\w+$)/mp;
my $subst = '$1*****$3$4*****$6';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";