# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:^\S+ \S+ |\G(?!^))\S+\K /\n/gm;t' <<< "Please ask your questions after the session is finished.
---
Please ask
---
Please ask your
---
Please ask your questions"