use strict;
my $str = 'Please ask your questions after the session is finished.
---
Please ask
---
Please ask your
---
Please ask your questions';
my $regex = qr/(?:^\S+ \S+ |\G(?!^))\S+\K /mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";