import Foundation
let pattern = #"(?:^\S+ \S+ |\G(?!^))\S+\K "#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Please ask your questions after the session is finished.
---
Please ask
---
Please ask your
---
Please ask your questions
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)