$re = '/(?:^\S+ \S+ |\G(?!^))\S+\K /m';
$str = 'Please ask your questions after the session is finished.
---
Please ask
---
Please ask your
---
Please ask your questions';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;