const regex = /(?:^\S+ \S+ |\G(?!^))\S+\K /gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^\\S+ \\S+ |\\G(?!^))\\S+\\K ', 'gm')
const str = `Please ask your questions after the session is finished.
---
Please ask
---
Please ask your
---
Please ask your questions`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);