using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^\S+ \S+ |\G(?!^))\S+\K ";
string substitution = @"\n";
string input = @"Please ask your questions after the session is finished.
---
Please ask
---
Please ask your
---
Please ask your questions";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}