import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^\\S+ \\S+ |\\G(?!^))\\S+\\K ";
final String string = "Please ask your questions after the session is finished.\n"
+ "---\n"
+ "Please ask\n"
+ "---\n"
+ "Please ask your\n"
+ "---\n"
+ "Please ask your questions";
final String subst = "\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}