#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((build|chore|ci|docs|feat|fix|perf|refactor|revert|style|test)(\([\w-]*\))?(!:|:.*\n\n((.+\n)+\n)?BREAKING CHANGE:)|💥)"
Local $sString = "feat!: message" & @CRLF & _
"feat(scope)!: message" & @CRLF & _
"feat(scope-scope)!: message" & @CRLF & _
"💥message" & @CRLF & _
"" & @CRLF & _
"feat(scope scope)!: message" & @CRLF & _
"feat: ABC-123 message" & @CRLF & _
"feat: message" & @CRLF & _
"feat(scope): ABC-123 message" & @CRLF & _
"feat(scope): message" & @CRLF & _
"feat(scope): ABC-123 message" & @CRLF & _
"feat(scope-scope): ABC-123 message" & @CRLF & _
"feat(scope scope): ABC-123 message" & @CRLF & _
"feat(scope): message"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")