// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((build|chore|ci|docs|feat|fix|perf|refactor|revert|style|test)(\([\w-]*\))?(!:|:.*\n\n((.+\n)+\n)?BREAKING CHANGE:)|💥)").unwrap();
let string = "feat!: message
feat(scope)!: message
feat(scope-scope)!: message
💥message
feat(scope scope)!: message
feat: ABC-123 message
feat: message
feat(scope): ABC-123 message
feat(scope): message
feat(scope): ABC-123 message
feat(scope-scope): ABC-123 message
feat(scope scope): ABC-123 message
feat(scope): message";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}