import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((build|chore|ci|docs|feat|fix|perf|refactor|revert|style|test)(\\([\\w-]*\\))?(!:|:.*\\n\\n((.+\\n)+\\n)?BREAKING CHANGE:)|💥)";
final String string = "feat!: message\n"
+ "feat(scope)!: message\n"
+ "feat(scope-scope)!: message\n"
+ "💥message\n\n"
+ "feat(scope scope)!: message\n"
+ "feat: ABC-123 message\n"
+ "feat: message\n"
+ "feat(scope): ABC-123 message\n"
+ "feat(scope): message\n"
+ "feat(scope): ABC-123 message\n"
+ "feat(scope-scope): ABC-123 message\n"
+ "feat(scope scope): ABC-123 message\n"
+ "feat(scope): message";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}