import re
regex = re.compile(r"^((build|chore|ci|docs|feat|fix|perf|refactor|revert|style|test)(\([\w-]*\))?(!:|:.*\n\n((.+\n)+\n)?BREAKING CHANGE:)|💥)", flags=re.MULTILINE)
test_str = ("feat!: message\n"
"feat(scope)!: message\n"
"feat(scope-scope)!: message\n"
"💥message\n\n"
"feat(scope scope)!: message\n"
"feat: ABC-123 message\n"
"feat: message\n"
"feat(scope): ABC-123 message\n"
"feat(scope): message\n"
"feat(scope): ABC-123 message\n"
"feat(scope-scope): ABC-123 message\n"
"feat(scope scope): ABC-123 message\n"
"feat(scope): message")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")