import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\{\\R\\h{2,}label:\\h+\"Other\",\\R\\h{2,}value:\\h+\"Other\",\\R\\},";
final String string = "{\n"
+ " label: \"Other\",\n"
+ " value: \"Other\",\n"
+ "},";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}