// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^{\R\h{2,}label:\h+"Other",\R\h{2,}value:\h+"Other",\R},"#).unwrap();
let string = "{
label: \"Other\",
value: \"Other\",
},";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}