$re = '/^{\R\h{2,}label:\h+"Other",\R\h{2,}value:\h+"Other",\R},/m';
$str = '{
label: "Other",
value: "Other",
},';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;