#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^ad[\w.-]+telewebion\.com$"
Local $sString = "telewebion.com" & @CRLF & _
"adengine.telewebion.com" & @CRLF & _
"ads.telewebion.com" & @CRLF & _
"ads-bsht1c82.telewebion.com" & @CRLF & _
"analytics.telewebion.com" & @CRLF & _
"cdna.telewebion.com" & @CRLF & _
"cdna-bsht1c86.telewebion.com" & @CRLF & _
"gateway.telewebion.com" & @CRLF & _
"hadeseh.telewebion.com" & @CRLF & _
"static.telewebion.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")