import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^ad[\\w.-]+telewebion\\.com$";
final String string = "telewebion.com\n"
+ "adengine.telewebion.com\n"
+ "ads.telewebion.com\n"
+ "ads-bsht1c82.telewebion.com\n"
+ "analytics.telewebion.com\n"
+ "cdna.telewebion.com\n"
+ "cdna-bsht1c86.telewebion.com\n"
+ "gateway.telewebion.com\n"
+ "hadeseh.telewebion.com\n"
+ "static.telewebion.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}