re = /^ad[\w.-]+telewebion\.com$/m
str = 'telewebion.com
adengine.telewebion.com
ads.telewebion.com
ads-bsht1c82.telewebion.com
analytics.telewebion.com
cdna.telewebion.com
cdna-bsht1c86.telewebion.com
gateway.telewebion.com
hadeseh.telewebion.com
static.telewebion.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end