import Foundation
let pattern = #"^ad[\w.-]+telewebion\.com$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
telewebion.com
adengine.telewebion.com
ads.telewebion.com
ads-bsht1c82.telewebion.com
analytics.telewebion.com
cdna.telewebion.com
cdna-bsht1c86.telewebion.com
gateway.telewebion.com
hadeseh.telewebion.com
static.telewebion.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)