// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^ad[\w.-]+telewebion\.com$").unwrap();
let string = "telewebion.com
adengine.telewebion.com
ads.telewebion.com
ads-bsht1c82.telewebion.com
analytics.telewebion.com
cdna.telewebion.com
cdna-bsht1c86.telewebion.com
gateway.telewebion.com
hadeseh.telewebion.com
static.telewebion.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}