use strict;
my $str = 'telewebion.com
adengine.telewebion.com
ads.telewebion.com
ads-bsht1c82.telewebion.com
analytics.telewebion.com
cdna.telewebion.com
cdna-bsht1c86.telewebion.com
gateway.telewebion.com
hadeseh.telewebion.com
static.telewebion.com';
my $regex = qr/^ad[\w.-]+telewebion\.com$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}