using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^ad[\w.-]+telewebion\.com$";
string input = @"telewebion.com
adengine.telewebion.com
ads.telewebion.com
ads-bsht1c82.telewebion.com
analytics.telewebion.com
cdna.telewebion.com
cdna-bsht1c86.telewebion.com
gateway.telewebion.com
hadeseh.telewebion.com
static.telewebion.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}