import re
regex = re.compile(r"^ad[\w.-]+telewebion\.com$", flags=re.MULTILINE)
test_str = ("telewebion.com\n"
"adengine.telewebion.com\n"
"ads.telewebion.com\n"
"ads-bsht1c82.telewebion.com\n"
"analytics.telewebion.com\n"
"cdna.telewebion.com\n"
"cdna-bsht1c86.telewebion.com\n"
"gateway.telewebion.com\n"
"hadeseh.telewebion.com\n"
"static.telewebion.com")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")