# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\.(\d+)\./.<br>$1./g;t' <<< "1. Place pastry on microwave safe plate.2. Heat on high for 3 seconds.3. Cool briefly before handling."