// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\.(\d+)\.").unwrap();
let string = "1. Place pastry on microwave safe plate.2. Heat on high for 3 seconds.3. Cool briefly before handling.";
let substitution = ".<br>$1.";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}