using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.(\d+)\.";
string substitution = @".<br>$1.";
string input = @"1. Place pastry on microwave safe plate.2. Heat on high for 3 seconds.3. Cool briefly before handling.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}