$re = '/\.(\d+)\./';
$str = '1. Place pastry on microwave safe plate.2. Heat on high for 3 seconds.3. Cool briefly before handling.';
$subst = ".<br>$1.";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;