#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\.(\d+)\."
Local $sString = "1. Place pastry on microwave safe plate.2. Heat on high for 3 seconds.3. Cool briefly before handling."
Local $sSubst = ".<br>$1."
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)