import Foundation
let pattern = #"\.(\d+)\."#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"1. Place pastry on microwave safe plate.2. Heat on high for 3 seconds.3. Cool briefly before handling."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #".<br>$1."#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)